Ushahidi Android App deployment problem


#1

Hello all,


I'm currently attempting to deploy the Ushahidi application to my android phone using the source code you've provided and Eclipse. I've already created new android projects from source and updated the build paths such that they each build correctly. My problem resides in how to successfully deploy them to the phone. Currently I create a generic project where I reference each of the individual projects as dependencies and launch using the Ushahidi project's default activity. I know that this cannot be the correct method for deploying the application as it crashes when its deployed to the phone. Any insights in how to correctly prepare the project in Eclipse such that I can deploy this application? I'm really interested in this application and would like to get the source code provided deployed so I can start playing with it.


Thanks for the help!!



#2

Hi,


Did you have any success?


Thanks,

Cam



#3

Howdy,


So far no. I tried importing the project using Eclipse's import feature however now I cannot set up the run configurations. I'm about to try importing each project individually to see if that works but so far no success.



#4

Still no luck. If anyone could assist a newbie in getting this project to compile and run that'd be great. I've tried importing the entire Ushahidi_Android project into Eclipse, I've tried creating new Android Applications from source which is the closest I've gotten as they project builds and deploys, I just can't actually run the application on my phone (EVO 3D). Continuously forces the application to close. This can't be that difficult, but apparently its not very intuitive either :


Help appreciated, thanks.



#5

Hi drmshake,


You might want to look at the build instruction https://github.com/ushahidi/Ushahidi_Android/blob/master/Ushahidi/BUILDING.txt


The project now supports ant.



#6

Hi eyedol,


I understood and did everything that BUILDING.txt says but I still get about 20 errors on the Manifest.xml file and can't Run it on the AVD device.

Can you please try to help.


Thank you.



#7

What did you do and how are you building the app? Are you using Eclipse or trying to build with ant?


Mind sharing some of the error messages you're getting?



#8

Hi Eyedol,


After your question, I went back to Eclipse and tried to do it again.

It turns out that, after I used Project->Clean, the errors desapeared but now, when I try to Run As Android Application it gives me a message saying "Android project Libraries cannot be Launched".

I opened the folders Core and Ushahidi from the github repository as projects on the Package Explorer and did everything that BUILDING.txt says.

I have a printscreen of my workspace here:

http://dl.dropbox.com/u/4272415/print_screen_ushahidi.jpg


Please advise.


Thank you



#9

You can't run Android library project. Try running the Ushahidi project instead not the Core.



#10

Hi Eyedol,


That's what I did. I tried to Run As... Android Application but I got that error message. I found it strange but that's what happened.



#11

Hello Eyedol,


I know that, probably, these are just newbie questions but would you please help me on this?


Thank you



#12

Not sure why. Mind sharing your .classpath file?


Maybe re-import the project and clean up the project.



#13

Hello,

I’m currently attempting to deploy the Ushahidi application using the source code you’ve provided and Eclipse. My problem resides in how to successfully deploy them to the phone.

Thanks for the help!!


#14

HI Amira, are you using the latest version of the Android app? We just released it last week

 

http://blog.ushahidi.com/2013/05/16/ushahidi-android-app-v3-1-6-is-here/

 


#15

@hleson Solved this with @amira over Skype sometime back. You can close this ticket