Ui_ problem


#1

Hi everyone,

I just installed v2.7.2 on WAMP Server v2.2.

Both front-end and back-end looks unusually frustrated by ui_main or ui_admin prefixes in every button, links and labels.

What Went Wrong?

See attachments please for your perusal.

Thanks


#2

Your deployment needs the localization files that are stored in a separate repository.You can go to https://github.com/ushahidi/Ushahidi-Localizations and download the translations directly from there and put them in you application/i18n/ directory.


#3

Thanks @brianherbert. Hey @ntagrafix, curious, did you clone this directly from github or get it from our download page? http://download.ushahidi.com?


#4

I had this exact problem and I cloned directly from GitHub. My applications/i18n folder was empty…adding in the localization files fixed the problem. Thank you.


#5

When you clone from github, you need to run the command “git submodule update --init” for it to automatically pull in your language files.

The language files were set up as a submodule from https://github.com/ushahidi/Ushahidi-Localizations


#6

Thanks Brianherbert …


#7

aodur this is what I just did


#8

Thanks a lot. i downloaded the Ushahidi_Localization as a zip from github and extracted it to C:\wamp\www\Ushahidi_Web-develop\application\i18n
worked like magic


#9

thanks a lot…worked like magic