SwiftRiver Login button


#1

Hi friends,


having found the conversation at


https://github.com/ushahidi/Swiftriver/issues/#issue/43


I installed SwiftRiver in Windows WAMP server with no problems at all but Login button at presentation web page does nothing so I can't go further.


I do not know if above conversation at github had a good end with a real solution. I can't find out but I think that would be good enough for me.


Does anybody know about this issue?


Thanks for all.



#2

Sounds like a problem with javascript and perhaps a bad install. email and we can take care of it jg~at~swiftly~dot~org



#3

I also have this problem on my LAMP setup. Can you suggest which files need checking please.



#4

ianrhw, this is a known issue. This has been fixed in the latest Swiftriver code at https://github.com/ushahidi/Swiftriver. There should be an update release soon.



#5

Many thanks for your swift reply. However, I seem to need a complete walkthrough to install swiftriver. I have installed ushahidi 2.0.1. Are you able to point me to a helpul step by step description?



#6

I am having the same problems with 0.5

eyedol, what exactly is the issue, and how has it been fixed? When can we expect an updated release? I'm attempting to evaluate swiftriver and potentially recommend it for use in the Emergency Management community, but I can't test it in this state.



#7

Hi


This may not be your problem but the symptoms are the same so just in case.


Possible Solution:



After install (see later, it may be relevant), check the swift-*web.htaccess file.


The RewriteBase property (near top) of the .htaccess file was set as below


# Installation directory

RewriteBase /web/


This did NOT correctly reflect the actual relative path of the root of the application for my install.


If you just copied the unzipped distribution, into the ‘htdocs’ directory of the web server, then the web directory may be one or two levels below the root directory.


In my case, I had to use the setting below – problem gone.


# Installation directory

RewriteBase /swift-0.5.0/web/


Install Process



1. Downloaded swift-0.5.0.zip

2. Unzipped to swift-0.5.0 directory

3. Copied the entire directory to the ‘httdocs’ directory (not sure how other stacks name the directory where webserver content is stored) using Windows Explorer

4. Started MySQL/Apache, navigated to http://localhost/ swift-0.5.0 and the Installation page appeared as per the docs.

5. Did the install

6. Got the following errors when accessing SwiftRiver for the first time:

. Incorrect URL error clicking on Accurate Content Tabhttp://localhost/swift-0.5.0/web/contentlist/get/accurate

. No action upon clicking on the Login button

7. Got irritable :) and being very stubborn when I’m like that, deduced that it was a relative path / base url problem

8. Searched everywhere for BaseURL type variables, they all seemed right, found .htaccess last!

9. Updated RewriteBase as at start of mail – problem gone (but may have found a source feed polling bug – another time)


LAMP Stack (Windows XP SP3 notebook)



I am running a slightly older release of XAMPP Stack (http://www.apachefriends.org/en/xampp-windows.html)details as below.


DISCLAIMER: I’m a Enterprise Java type so I’m winging the LAMP stuff - I can’t even remember why I chose XAMPP!


NOTE: I had to add PEAR Logging to this base install to satisfy SwiftRiver - winged that too, never even heard of PEAR before…


###### Apache Friends XAMPP (Basis Package) version 1.7.3 ######


+ Apache 2.2.14 (IPV6 enabled)

+ MySQL 5.1.41 (Community Server) with PBXT engine 1.0.09-rc

+ PHP 5.3.1 (PEAR, Mail_Mime, MDB2, Zend)

+ Perl 5.10.1 (Bundle::Apache2, Apache2::Request, Bundle::Apache::ASP, Bundle::Email, Bundle::DBD::mysql, DBD::SQlite, Randy Kobes PPM)

+ XAMPP Control Version 2.5.8 (ApacheFriends Edition)

+ XAMPP CLI Bundle 1.6

+ XAMPP Port Check 1.5

+ XAMPP Security 1.1

…


BTW – To all Ushahidi people, great work…


Regards

Jim Nicolson



#8

Hi jimnicolson


I'm installed Swiftriver with XAMPP, but this time on Windows Vista. I already did the install process as you described, everything went fine, but same issue, the login button does nothing when is pressed.


Excuse me, where is the htaccess file you mentioned?? after installation a web folder was created inside the swift-0.5.0 folder (C:xampphtdocsswift-0.5.0web), but there's no htaccess file inside.


I'm looking for on the right path??


Thanks



#9

Hi Josef


in your case, the .htaccess file should be in C:xampphtdocsswift-0.5.0web.


So you are on the right path. However, I just noticed that it's marked as Hidden (maybe because it starts with a .)on my machine. It's a dev type notebook and I always set explorer (on XP) to show Hidden Files and Folders (Tools | Folder Options | View on XP).


I'm not sure how to do this on Vista - so check the Help...


HTH



#10

Hi jimnicolson,


Yes, you were right, that file was marked as hidden. I did the changes in the way you described and voila! the login button now works :)


But my joy ended when I type my username and password and Switfriver replied with "wrong credentials". I checked the RiverIdConfig on webmodulesriveridclasses and all the settings were fine. I went to the DB and there were not a 'users' table created.

I created myself with the query described on the RiverIdConfig, and set an user and password fields but still nothing, It keeps saying "wrong credentials"


I know this is out of thread, but any help would be appreciated. Thanks a lot



#11

Hi Josef


I'm not sure I can help but some thoughts...


1. Are you using the corerct credentials :)


admin username: admin

Password: [whatever you entered during install process]


NNB: RiverIdConfig is the Database Username and password. Not the Swift admin user name and password for login.


2. missing 'users' table.


This seems an indication of an install problem in my mind.

My install notes (yes I keep a log!) - I checked the database straight after install and did note that there were tables there.


I did't write down which ones! (This was before I'd resolved the .htaccess problem.)


However, there was only a couple so the app may create them on the fly. Haven't trawled the code though. Some were defiitely created after I set up a source.


3. Creating 'tables' and populating by hand.


I'd be very surprised if you do this and the system worked (pasword is encrypted) but...


Personally, I'd clean out the database and the Swift install and do it again. Make sure you write down the admin password just to be certain it's not a simple user error (sorry, but I've made this mistake myself a few time!)


BTW: In the location below (adjust for your location), there is a log.log file. This is logging the message processing. It does tell you that the underlying subsystem is operating.


C:softwaredevserverXAMPPxampphtdocsswift-0.5.0coreCache


Best I can do. I suspect wrong credentials...


Regards

Jim Nicolson