SSH phinx migrate command Permission Denied on Bluehost


Hello All,
Is there anyone here who have hosted Ushahidi 3 or greater on bluehost or other shared hosting,
I am having some permission issues performing the phinx migrate command.

below is what I am getting… [~/public_html/platform]# ./bin/phinx migrate -c application/phinx.php
-jailshell: ./bin/phinx: Permission denied


Not running currently on Bluehost, but your problem may be solved by:

chmod +x ./bin/phinx
./bin/phinx migrate -c application/phinx.php

or alternatively…

php ./phinx.php -- migrate -c application/phinx.php

Hope this helps!


Hello David,
Thanks, I am no longer getting the Permission Denied error
but when I run the following : php ./phinx.php – migrate -c application/phinx.php
I get “Could not open input file: ./phinx.php”

and when I run this:
chmod +x ./bin/phinx
./bin/phinx migrate -c application/phinx.php

Nothing happen and no table is created in the db


Thanks David,
I have successfully deployed Ushahidi 4 on a Bluehost Shared host.

Everything looks good as expected.


Glad to hear Timothy!