Post Installation Map Display Errors!


#1

Hi all

I have completed a seamless installation recently, and now testing the site.

I am just having a few problems with displaying the map points on my installation of Ushahidi.

As I am not very good at programming, I need help with sorting this out.

They are mostly to do with displaying the incidents on the Google map.

Error description:

1. When I click on the 'REPORTS' link from the home page, I get a pop up window with this error: "Error in loading GML file http://mysite/index.php/json/?i=11" >>>> When I click OK, it takes me to this page: (http://mysite/index.php/reports/view/9)


2. The main page - mysite/index.php never displays the reported incidents on the underlying google country map.



I have re-installed the Ushahidi application over and over again without any luck. Any insights will be highly appreciated. Cheers



#2

Make sure URL rewrite works. Check if you can go to the site so http://mysite/reports/view/9



#3

Hi Eyedol, thanks for your reply.

how can I tell if URL rewrite works. In my site's .htaccess file the URL rewrite is enabled. Where else can I check?

++++++++++++++++++++++++++++++++

These are the settings in my .htaccess file -->

# Turn on URL rewriting

RewriteEngine On


# Installation directory

RewriteBase /

++++++++++++++++++++++++++++++++

In config.php I have this setting --> $config = '/index.php/';

++++++++++++++++++++++++++++++++



When I try to access http://www.mysite.com/reports/view/9, I get a "page not found" error

But I just inserted 'index.php/' in the URL (http://www.mysite.com/index.php/reports/view/9) and the page loads, albeit with the following error message:


Error in loading GML file http://www.votereportng.net/index.php/json/?i=9


When I click OK on the pop-up error dialog box,the map still doesnt show the Incidents plotted.

your help is very much appreciated. Cheers



#4

Hi again Eyedol,

At the backend, the incident reports are plotted ok on the map.

I can view this URL OK - "http://mysite/index.php/admin/reports/edit/9"


So the problem seems to be at the front end only.

Cheers



#5

Same problem, are you running on IIS or *nix? I'm running on IIS 7.5 / Windows Server 2008 R2. Other than maps it seems fine, just a test instance to play with..



#6

I seem to be getting the same error. I have tried everything I can think of (and every solution I can find on here). I am not winning.


In addition, the approve buttons through up an error about file headers, cache.php. file_put_contents.


Has anyone any idea?



#7

Could you check this thread http://forums.ushahidi.com/topic.php?id=210


How about clearing up the cache folder.



#8

Hi eyedol, the other post was me. I've since changed my login to take my email address off line.


I suspect some of these problems are a clash between Kohana and Apache (not sure yet), so I am documenting how to load Ushahidi on local host and I will post here when I know I've got it right.


I think we need instructions 'one level lower' . You say happily clear up the cache folder. Cache appears several times. Which one? And do you really mean this? I've only just installed. It's the install that is frustrating people.



#9

Hi jobucks,

It seems your problem has to do with mod_rewrite. check this post http://forums.ushahidi.com/topic.php?id=113



#10

Hi,


I had the "Error in loading GML file ..." problem, too. Using XAMPP on Windows XP, the following post by hfastt fixed the problem for me: http://forums.ushahidi.com/topic/uncaught-php-error-file_put_contents



#11

I have the whole application working fine except for the Map API I put in. (If that is the problem?) I set about telling the application where I was located and save settings so that location is what should pop up in the first map window when you load Ushahidi but I am still getting the default Nairobi landmark.


Any suggestions?

Thanks



#12

try this /application/views/main_js.php:

var default_json_url = "<?php echo 'index.php/'.$json_url ?>"



#13

Great choice for a quick setup server