Android App Maps aren't Refreshing


#1

We can submit reports through the web & through the Android App Ver 3.9 iwth no problems, but they never show up on the Apps Map no matter how many times you refresh. Reports show up on the website & within the App Reports section, but they never show up on the map.


#2

@NexMillenia You’ve to approve the report first( from the admin dashboard of your deployment ) before they show up on the front page’s map. I’m assuming you’re saying you can’t see the reports on the front page?


#3

This is all after that. The reports are all approved and everything has happened. They show up on the website & it’s map, but they never show up on the Android’s App Map. We can go to our Ushahidi Website & see the reports on the maps there, but they never show up on our Android App Map either on phone or tablet. That’s what makes this hard to figure out. How can they show up on the map at the website, but never in the Android App on Smartphone or Tablet. We resfresh many times on the Smartphone & Tablet and no luck.


#4

Funky. How about the report list? Does it show in the report list?


#5

I strongly suspect you might have found a bug in the Android app.


#6

Funny you should mentioned that. Are report list in the App doesn’t have them and also only shows us the last 20 reports listed. We have thought that was a bug also. Shouldn’t the reports list on the App show all of the approved reports like the website? We might have found 2 bugs.

  1. Approved reports don’t show up on App map.

  2. Reports lists doesn’t show them and only shows about 20 reports when we have as many as 100 approved that are visible from the website.


#7

You should be able to increase the number of reports from 20. If you increase the limit value and the report shows, then it means new reports don’t show up depending on the limit value set.


#8

Ok, so where do we increase the limit at? Thanks for your quick responses for sure. :smiley:


#9

At the Map report listing screen then settings. So.

Maps -> Settings


#10

We are running Ver 2.7 of Ushahidi. Is this over in Dashboard somewhere or something in the App itself?


#11

The app itself. Are you running a white-labelled app? It should be on the actionbar or should show up when you press the menu key


#12

I just knew you where speaking about within the App. We are using the Android App from Google Play Store Ver 3.9 and in it’s menu we only have the following choices;

Maps - Under this you have several map related options, but nothing else
Admin - just takes you to the Admin section
About - just displays info about Ushahidi & Ver 3.9

Nothing else, sorry. That’s the way it looks on a Tablet & Smartphone


#13

Good.

So on the map listing screen, you don’t see options this to tap it or when you tap on this menu on the phone, no option shows?

Are you able to clear the map list?

Trying to figure out why you don’t see the settings option.


#14

Success at last. The “settings” option on the App is only displayed where you are going to select your map. It would be the menu option on the phone like your second image is displaying, but it only works for “settings” before you select a map. We increased our # of reports to see and refreshed our reports listing & they showed up immediately. We had to exit the App and reenter it again, do another refresh to get the map in the App to finally show us everything. Really appreciate your efforts to stick this one through with us. Hope in a white label version these items can be determined by us for all our users. This is something we would not like for them to experience or have to deal with. Thanks again. :smiley:


#15

Glad to hear it’s working. Best fix for this is for us to change the sorting order. To display the newest first.


#16

Agree with that & maybe have an unlimited load of reports option also, for larger deployments. Bit of sad news though, tried to make the same changes on Android tablet running the App & you never get to see the “settings” option. Everything I tried from there just keep bringing up the “add report” option only. Just something else to work on. LOL.